What browsers are support?

While Banner 9 supports all current browsers, Banner 8 forms still require the Java plugin to function. Banner 8 supported browsers (with Java enabled) including Internet Explorer and Safari. Until all Banner 8 forms are converted to Banner Admin Pages, the recommendation is to use Internet Explorer or Safari.
* Internet Explorer must be chosen by users who need to run Banner 8 In–house modules / Reports.